---
title: "How do I clear the Linux CUPS print queue?"
canonical: "https://kb.myframeworks.com.au/space/PROSTIXV48DOC/31098020/How%20do%20I%20clear%20the%20Linux%20CUPS%20print%20queue%3F"
format: markdown
---
Note : The information within this section will be hidden before the FAQ is published.   ERROR MESSAGE:   How do I clear the Linux CUPS print queue?   CAUSE:   The CUPS print spooler on Linux by default only handles up to 500 jobs in its queue. Once more are queued, an error is displayed and no further Linux printing will work until the queue is cleared.   SOLUTION:   To resolve this issue, perform the following: 1. Confirm you have this problem by checking the number of queue jobs with the command:  lpstat -o | wc -l 2. Log in as the root user. 3. Run the command:  cancel -a - 4. Re-check the queue status:  lpstat -o FOR FURTHER INFORMATION REFER TO: https://www.cups.org/documentation.html http://kb.eclipseinc.com/kb/how-do-i-manage-linux-print-queues/ IF THIS FAQ DOESN’T RESOLVE YOUR  ISSUE: Contact  Sterland Support .